Layout Bugsplat while resizing Condoc Drawing Viewport

00_Home 00_Pro Forum ConDoc 5 Layout Bugsplat while resizing Condoc Drawing Viewport

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #27500


    I ran into an issue with Layout and don’t really know how to fix it. I imported a Condoc Drawing from my Scrapbook and needed to resize it. When I did, the Bugsplat occured. I tried Ungrouping and resizing each viewport separately and it was ok. But it would be so much easier if I could actually resize them all together.

    Mike Brightman

    Hard to say on this…  Once the scrapbooks are dragged in there’s no special “ConDoc” operations happening in the background.  They are just LayOut viewports.  I would do the usual load reduction on the graphics card.  Turn down the edit quality/resolution, turn off auto render.  You might even try dragging it into an empty presentation to see if it still acts up.  If it does, I would look for something heavy in the scene that LayOut is trying to render.  Are there any super heavy objects that LayOut is trying to flatten?  Maybe swap it for a 2d graphic/3d object?


    In the meantime I figured out that only one viewport causes the problem. It’s the one with Dashed Style with dashes enabled. I just moved from 2019 to 2021 version. Is there something different in dashes presentation in Sketchup or Layout? Should I change some style settings?

    Mike Brightman

    That could be the culprit!  I think it was SU2019 that brought vector dashes…  I would definitely recommend using the latest Architect drawing set to leverage the vector dashes.  You might have to rerun the plan generator and delete out the old scenes for drawings that were using the raster dashes.  I am just speculating here having not seen your model.  If you share it I could take a look.


    Here’s the link:

    It’s not super clean yet and I still have to put things on layers, etc. but I just wanted to test the new version and boom… the problem occured.

    Mike Brightman

    Thanks for sharing!  First thing I noticed is your rendering resolution is set to medium.  This renders all raster viewports at 150ppi.  You should set this to low so raster viewports render at 96ppi.  That will take some weight off your graphics card.  The document setup settings travel with your file…

    Also…  I ran SketchUp’s free material resizer extension to knock down some of the large images embedded in the model.  Maybe you need them for vray, but usually you don’t need texture images over 512.

    As far as I can tell you are using the latest vector dashed styles.  I think it’s just a combination of a heavy model (my version is only 69mb) and unnecessary render quality in layout.

    In the LayOut file you sent, there are a lot of stacked viewports for one drawing.  Not sure if they are all necessary, maybe you consolidate some of those viewports?

    I opened your file, and sure enough when I stretched the viewport it crashed.  After my cleanup it doesn’t.  Here’s my file… DOWNLOAD

    Let me know if that helps!



    Another hint. After I put it from Scrapbooks to the page  and it appears as unrendered.

    And there are two paths:

    When the next step is simpy resizing – there’s a bugsplat


    When I first re-render the viewports and then resize everything works fine.

    The only thing that bothers me is that it never happened to me in the previous versions.


    Is there any reason why the insterted drawing appears as unrendered? Is it normal and I should live with it or something’s actually wrong?

    [email protected]

    Hi Michael and Arkadiusz,

    I am having the exact same problem on a newly created, very basic design so far. The first time I ran the plan generator, went to layout and dragged the construction plan drawing in and tried to resize it, Layout crashed and bugsplatted.  When I brought in a perspective drawing it did not do this upon resizing. However, when I tried what Arkadiusz suggested at the end of this thread (rendering before resizing), it didn’t crash/bugsplat.

    I’m glad there appears to be a workaround, but it doesn’t seem like we should have to render before resizing.  This isn’t a heavy model either, there are only a couple of materials and they are native to Sketchup and one component that’s only 36kb.  I also set the rendering resolution to low before I re-tested.

    Thank you,


    [email protected]

    Hi Michael,

    One other thing I noticed, when I tried to render via the Sketchup Model tab in Layout is that nothing was enabled. I always use my keyboard shortcut to render so I didn’t notice it at first, but it’s saying that no model is selected. I’m sure if I ungroup everything it would be available, but I didn’t think this was supposed to be necessary or the recommended way to use Condoc.  Let me know what you think.

    Screenshot of Layout Sketchup Model dialogue

    Mike Brightman

    Hello Karen!

    I’m glad to know you are at least able to work around it.  I find that LayOut can be very temperamental and I’ve really learned to walk on egg shells when I have a heavier project.  In my experience, the usual cause of LayOut crashing is not the 3d model, it’s an image.  Could be in a material, or in a style…

    Regarding your second post, all ConDoc Drawings are grouped, even if there is only one viewport.  So you will need to double-click in to select a viewport, then you will see the render options.  Or just ungroup it and disable sketchup model edits in preferences.  Check out this video!

    Let me know if that helps!


Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.