Draft Mode

00_Home 00_Pro Forum ConDoc 4 Draft Mode

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25898
    Ruben Benitez
    Participant

    How can I use Orbit in draft mode? I have some 2d work I’m doing trying to use draft mode but I’ve got some stuff in different Z planes and I want to see what needs to move to flatten all the 2D linework

    #25902
    Ruben Benitez
    Participant

    Second issue in draft mode. I seem to be getting a lot of lag when I move things. My drawing is 100% 2D and everything in the file is in draft mode. It seems like it’s an issue when it has to generate the face that we never see in draft mode. Is there anything I can do to avoid this issue?

    #25903
    Mike Brightman
    Keymaster

    Hello Ruben,

    Unfortunately, due to the style that’s set up for Draft¬† Mode, the Orbit button/feature is removed (as far as I know it to be). This is intentionally done to achieve the 2D CAD styled interface, and it’s important to note that although it will appear to be a traditional CAD interface, it will not function the same as a standard CAD program – meaning that the 3D orbit will not function the same.

    You can always generate your scenes after you finish your detail drawings and orbit around in those. We do that often to verify that certain elements are present in the plan drawings. Although it will be a bit different with the scenes that are created from Draft Mode as the stacked viewports will be line weights and fills controlled by their corresponding layers.

    On your second issue, the lag could be caused by excessive line segments (if you imported details from another CAD program) – if this is the case, we usually re-draw arcs, circles, and other high-segmented lines in SketchUp to simplify things.

    One other thing you can try is purging your model/file. Go to Window>Model Info>Statistics and click the “Purge Unused” button – this will clear all the lingering things that can bog down your model/file.

    One last thing you can try is changing your OpenGL Settings. Go to Window>Preferences>OpenGL and uncheck “Use fast feedback” and “Use maximum texture size”. Also make sure your Multisample anti-aliasing is set low (4x or 2x).

    #25904
    Mike Brightman
    Keymaster

    I forgot to mention that if you are on SketchUp 2019, you can also consider drawing your details inside of LayOut as opposed to using Draft Mode. We’ve actually made the switch to LayOut and in many ways it’s been easier with less to export and re-link. LayOut 2019 has a scaled drawing function and you can easily adjust the line weights as you would in any other program. Something to consider!

     

    #25914
    Ruben Benitez
    Participant

    Luke …. as always thank for the insight. I have gone thru and redrawn a lot of the multi segmented line work, purged and things have gotten better. I too have started to use the drawing scale feature in Layout to draw details. This project was someones ACAD 2d handoff that I didn’t want to model so I tried DRAFT mode for the first time and it’s worked pretty well.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.